Call Completion Failures
Incident Report for CallRail
Resolved
All our upstream carriers are confirming normal call completion rates at this time, so this incident is considered resolved.
Posted 4 months ago. Nov 06, 2017 - 18:00 EST
Monitoring
Our monitoring tools indicate that the majority of calls are completing as expected again. We are still monitoring closely with our carriers to confirm resolution, but expect that impact to customer numbers has been minimized at this point.
Posted 4 months ago. Nov 06, 2017 - 17:05 EST
Investigating
We are currently investigating elevated rates of call completion failures. This seems to be affecting about 20% of destination numbers. Our monitoring tools indicate that the failures span across multiple upstream carriers, so we suspect this issue exists at a backbone carrier level. We are working with our carrier partners to isolate the problem and resolve this as quickly as possible.
Posted 4 months ago. Nov 06, 2017 - 16:52 EST