Decreased Rate of Completed Calls With Upstream Provider.
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 02, 2017 - 09:48 EST
Monitoring
We have Identified an issue with call completion rates with one of our upstream providers.

We have moved call traffic over to a different provider for termination to mitigate the issue, and are monitoring call completion rates. Preliminary indications are that the issue is resolved.
Posted 9 months ago. Mar 02, 2017 - 09:27 EST