Inbound calls to some phone numbers are failing
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 14, 2018 - 20:39 EDT
Monitoring
Our carrier partner is reporting that this issue has been resolved. We are seeing signs that the affected numbers are working again, and are monitoring closely to ensure full recovery.
Posted about 1 month ago. Mar 14, 2018 - 18:16 EDT
Update
Our carrier partner is still working with an upstream carrier to fully resolve this interruption. We can confirm that this only affects a small percentage of tracking phone numbers, and we will continue posting as updates are available.
Posted about 1 month ago. Mar 14, 2018 - 17:56 EDT
Identified
An upstream carrier is experiencing issues routing calls for a small percentage of tracking phone numbers. We will provide an update when we have more information.
Posted about 1 month ago. Mar 14, 2018 - 16:53 EDT