Support Ticketing System Issues
Incident Report for CallRail
Resolved
Our ticketing system is back to normal operation at this time.
Posted about 1 year ago. Nov 06, 2017 - 16:05 EST
Identified
We are currently experiencing issues with our support ticketing system. If you've submitted a request to support@callrail.com or through our website, it may take a little longer to get back to you than normal. Because of this, our phone support team is a little busier than usual as well. For urgent issues, please call us and leave a message if you can't get through right away. We'll get back to you shortly.

None of this affects the application or call routing, both of which are performing normally.
Posted about 1 year ago. Nov 06, 2017 - 13:53 EST