Application Unresponsive
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 19, 2018 - 11:33 EST
Monitoring
A fix has been implemented and we are monitoring performance.
Posted 7 months ago. Nov 19, 2018 - 11:13 EST
Investigating
We are currently investigating issues accessing the CallRail application. Calls are being routed via backup routing.
Posted 7 months ago. Nov 19, 2018 - 10:50 EST
This incident affected: Application Dashboard, Call Routing, and Backup Call Routing.