Billing Outage
Incident Report for CallRail
Resolved
Our provider has resolved this issue and billing functionality is restored.
Posted Aug 21, 2020 - 21:00 EDT
Identified
Our billing services provider is experiencing an outage. While they work to resolve it, customers will be unable to enter or change billing information (such as credit cards), and invoice information may be unavailable.
Posted Aug 21, 2020 - 17:52 EDT