Application slowness
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 17:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results to determine whether further intervention will be necessary.
Posted Mar 21, 2022 - 17:21 EDT
Identified
We have identified factors contributing to the current slow performance and are deploying fixes.
Posted Mar 21, 2022 - 15:59 EDT
Investigating
We are investigating an issue causing general slowness of our web dashboard and Lead Center call data. Call routing is unaffected.
Posted Mar 21, 2022 - 15:14 EDT
This incident affected: Lead Center (Lead Center General) and Call Tracking (CallRail Web Application).