Twilio Issues & Lead Center Outage
Incident Report for CallRail
Resolved
Upstream Twilio issues have been resolved and CallRail functionality has been restored.
Posted Mar 28, 2022 - 15:48 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 28, 2022 - 15:14 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 28, 2022 - 12:41 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 28, 2022 - 12:31 EDT
Monitoring
Twilio has remedied its outage and is waiting on a full recovery of their systems.

We expect any missed CallRail events during this period to begin to processing after resolution from Twilio, although there may be a delay as our application works through a backlogged queue of events.
Posted Mar 28, 2022 - 12:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 28, 2022 - 11:46 EDT
Update
We are continuing to investigate this issue.
Posted Mar 28, 2022 - 11:43 EDT
Update
We are continuing to investigate this issue.
Posted Mar 28, 2022 - 11:39 EDT
Update
We are continuing to investigate this issue.
Posted Mar 28, 2022 - 11:34 EDT
Investigating
We are experiencing issues related to the processing of SMS and Call events due to an upstream issue with our provider, Twilio.

Any functionality relying on Call routing/recording, SMS routing, and Lead Center may be impacted by this upstream outage.

See https://status.twilio.com/.
Posted Mar 28, 2022 - 11:31 EDT
This incident affected: Call Tracking (CallRail Web Application, Call Routing), Lead Center (Lead Center General, SMS), and Call Recording.