Intermittent delays
Incident Report for CallRail
Resolved
This incident is resolved.
Posted Mar 29, 2022 - 15:22 EDT
Investigating
We are experiencing intermittent delays with our system due to internal application timeouts. Impacted functionality includes processing call related events and page load times. Our internal teams are aware of the issue and will continue to investigate.
Posted Mar 29, 2022 - 14:59 EDT
This incident affected: Call Tracking (CallRail Web Application) and Lead Center (Lead Center General).