Application Dashboard unavailable to Safari users
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 17:36 EST
Investigating
We are currently investigating an issue that is preventing Safari users from using the application dashboard.
Posted Feb 04, 2021 - 16:47 EST
This incident affected: Application Dashboard.