Billing Outage
Incident Report for CallRail
Resolved
Our vendor has resolved this issue.
Posted Aug 24, 2020 - 10:27 EDT
Identified
Our billing provider is again investigating an issue with their service; certain CallRail billing functions (including updating payment information) are temporarily unavailable.
Posted Aug 24, 2020 - 08:35 EDT