Ongoing provider incident causing intermittent call completion issues for a small number of customers
Incident Report for CallRail
Postmortem

Issues internal to one of our upstream telephony providers have caused intermittent service problems for us recently:

  • Caller ID data has been periodically unavailable or available with degraded or less detailed information
  • Person-level attribution data has been temporarily unavailable, but is added to our record of the call when the provider’s service becomes available again
  • Calls to or from numbers provisioned through this provider (a minority of our overall numbers) may fail
  • Incomplete or spurious calls from numbers provisioned through this provider may appear in your call logs

These issues are unfortunately outside of our control, but we will continue to monitor them, and if they continue we will explore alternate providers for some of these services to improve reliability for our customers.

Posted Sep 30, 2021 - 10:17 EDT

Resolved
Our provider has resolve this incident, but we are continuing to monitor in case it recurs.
Posted Sep 30, 2021 - 09:05 EDT
Monitoring
An ongoing issue at one of our upstream telephony providers is causing call routing issues for some calls involving numbers provisioned through that service. We do not have a time to resolution from our vendor at this time, but we are continuing to monitor the situation.
Posted Sep 29, 2021 - 19:58 EDT
This incident affected: Call Tracking (Call Routing).