Internet-wide DDOS Attack
Incident Report for CallRail
Resolved
By all indications, our support system and call handling has been fully restored at this time. The upstream DNS provider reports that the attack is continuing, so we will continue to monitor for any further fallout from this issue.
Posted 11 months ago. Oct 21, 2016 - 16:41 EDT
Update
We're still hearing reports of intermittent issues with call routing and our support system. We're really sorry about this, and we're doing everything we can to work around it. Unfortunately this seems to be a large-scale criminal attack on core internet infrastructure, and most of the trouble is further upstream than any of our systems. We will continue posting updates as they become available.
Posted 11 months ago. Oct 21, 2016 - 14:56 EDT
Update
One of our upstream telephony providers is now reporting problems with call completion rates related to this DNS DDoS. This affects a minority percentage of our tracking phone numbers. They are working to restore service as quickly as possible.
Posted 11 months ago. Oct 21, 2016 - 12:58 EDT
Monitoring
DDOS attacks on DNS infrastructure are causing intermittent issues for a wide array of internet services today. Although our Application, Call Routing, and DNI and Keyword Tracking are so far unaffected by this issue, problems with external services may result in unexpected behavior.

We are aware that our support ticketing and documentation system provider has been experiencing availability issues, and they are aware of the problem and working to correct it as quickly as possible.

We are monitoring the situation as it develops, and will post here if any further information becomes available.
Posted 11 months ago. Oct 21, 2016 - 12:14 EDT