Sign-on issues
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 14:16 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2024 - 13:38 EDT
Investigating
We are receiving reports of errors when logging in from a small subset of users. We are actively working on a resolution and apologize for any disruptions you are experiencing related to this issue.
Posted Jun 21, 2024 - 13:06 EDT
This incident affected: Call Tracking (CallRail Web Application).