Lead Center - Agent View

Incident Report for CallRail

Resolved

We have identified and deployed a fix but will continue to monitor.
Posted Mar 17, 2023 - 14:04 EDT

Investigating

There are some lead center agents that are unable to access the agent view in Lead Center. We are currently investigating.
Posted Mar 17, 2023 - 13:24 EDT
This incident affected: Lead Center (Lead Center General).