Service Provider Performance Issues Impacting Plan Changes & Invoice Viewing
Incident Report for CallRail
Resolved
Performance issues have been resolved and functionality has been restored.
Posted Sep 04, 2024 - 19:45 EDT
Update
We are continuing to monitor. As a reminder, the following actions are unavailable during this time:
- Plan changes
- Invoice viewing
- New trial sign up with credit card
- Adding/updating credit card to existing accounts
Posted Sep 04, 2024 - 18:32 EDT
Update
We are continuing to monitor.
Posted Sep 04, 2024 - 16:33 EDT
Monitoring
Due to performance issues with one of our service providers, we have temporarily disabled the following:
- Plan changes
- Invoice viewing
- New trial sign up with credit card
Posted Sep 04, 2024 - 14:58 EDT