Twilio connectivity issues
Incident Report for CallRail
Resolved
Our third party provider has resolved their incident. Functionality should be back to normal.
Posted Dec 29, 2022 - 21:36 EST
Update
We are continuing to monitor for any further issues while our third party provider investigates. https://status.twilio.com/
Posted Dec 29, 2022 - 18:52 EST
Monitoring
One of our third party providers is experiencing failures with SMS delivery and some outbound voice calls. We will continue monitoring and will update when they have resolved the issue.
Posted Dec 29, 2022 - 17:57 EST
This incident affected: Lead Center (Softphone, SMS).