Ongoing database performance issues

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted Jul 21, 2022 - 15:37 EDT

Monitoring

Our fix has gone into effect and metrics indicate performance has returned to normal. We will continue to monitor the state of platform performance and, on the basis of results here, are pursuing additional options to further improve performance for our most frequently used reports.
Posted Jul 21, 2022 - 14:21 EDT

Identified

We are aware of and pursuing solutions for database slowness impacting access to calls data via reports or our API. This issue is related to the incident on 7/19. Some reports may time out, displaying the message 'Invalid Report Configuration'. The team is actively working this issue.

Calls continue to be routed and tracked as normal.
Posted Jul 21, 2022 - 09:23 EDT
This incident affected: Call Tracking (CallRail Web Application, CallRail Call Tracking Mobile App) and Integrations (API).