Email delivery delays
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 15:00 EDT
Monitoring
A fix has been implemented by the upstream vendor and we are monitoring the results.
Posted Jun 09, 2022 - 13:16 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2022 - 13:01 EDT
Identified
Due to an issue with an upstream provider, the delivery of email notifications is delayed.
Posted Jun 09, 2022 - 12:56 EDT
This incident affected: Email Notifications.