The issue with our downstream provider has been resolved and caller ID information is no longer delayed. Current/in-progress calls will display the expected information. Prior calls that were received while the incident may still show as "Unavailable", but we will backfill any missing data.
Posted Apr 19, 2025 - 15:02 EDT
Identified
We have identified that this issue is caused by a downstream provider and we are working with them to resolve this issue. In the meantime, all calls are routing correctly although caller identification data may be missing. We will continue to monitor and work with our provider to fix this issue as quickly as possible.
Posted Apr 19, 2025 - 13:44 EDT
Investigating
We are currently investigating an issue that is causing the receipt of caller ID information to be delayed. Caller names may display as "Unavailable" in Lead Center, the call and text activity logs, and in reports. Call routing is not impacted.
Posted Apr 19, 2025 - 13:04 EDT
This incident affected: Lead Center (Lead Center General).