All missing caller ID information has been backfilled.
Posted Mar 04, 2025 - 07:28 EST
Update
We are still working to recover caller name information for calls received between approximately 9:12am ET and 11:02am ET. Calls received since 11:02am are processing normally and have the expected caller ID information.
Posted Mar 03, 2025 - 15:48 EST
Monitoring
The issue is resolved and caller ID information is no longer delayed. Current/in-progress calls will display the expected information. Prior calls that were received while the incident may still show as "Unavailable", but we expect to backfill missing data shortly.
Posted Mar 03, 2025 - 11:30 EST
Update
We are continuing to investigate this issue.
Posted Mar 03, 2025 - 10:39 EST
Investigating
We are currently investigating an issue that is causing the receipt of caller ID information to be delayed. Caller names may display as "Unavailable" in Lead Center, the call and text activity logs, and in reports. Call routing is not impacted.
Posted Mar 03, 2025 - 09:45 EST
This incident affected: Call Tracking (CallRail Web Application) and Lead Center (Lead Center General).