Reports of MMS Delivery Failures to Some Carriers

Incident Report for CallRail

Resolved

We are observing successful MMS delivery across all networks, and our vendor has resolved their incident.
Posted May 05, 2023 - 17:54 EDT

Monitoring

The vendor has implemented a fix for MMS delivery for the affected subset of long codes. We will continue to monitor the situation.
Posted May 05, 2023 - 15:32 EDT

Investigating

We're monitoring reports by a vendor of MMS delivery failures when sending messages to multiple networks in the U.S. over subset of long codes. We'll update as more information becomes available.
Posted May 05, 2023 - 11:48 EDT
This incident affected: Text messaging (MMS).