Intermittent slow page loads in the app dashboard
Incident Report for CallRail
Resolved
This incident has been resolved.

Please note that while not initially reported as an impact, some customers may have seen delays in processing of transcripts and related functionality.
Posted Apr 03, 2023 - 15:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2023 - 13:10 EDT
Investigating
We are aware that some users are experiencing slow page loads in the app dashboard and are investigating the issue.

Call routing is unaffected, however, Lead Center customers may experience issues handling calls.
Posted Apr 03, 2023 - 12:49 EDT
This incident affected: Call Tracking (CallRail Web Application, CallRail Call Tracking Mobile App) and Lead Center (Lead Center General).