Lead Center incoming call notification issue on iOS

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted May 09, 2026 - 07:15 EDT

Identified

We're currently experiencing issues with incoming call notifications for Lead Center on iOS devices. Android devices are not impacted. The team has identified the issue and a fix is being implemented.
Posted May 08, 2026 - 14:09 EDT
This incident affected: Lead Center (Lead Center Mobile App).