Degraded Application Dashboard Performance
Incident Report for CallRail
Resolved
This incident has been resolved. No application downtime was logged.
Posted 18 days ago. Aug 02, 2019 - 18:09 EDT
Monitoring
We have isolated the problem to a poorly performing database query, and have implemented a fix. We are currently monitoring to ensure performance remains normal.
Posted 18 days ago. Aug 02, 2019 - 17:09 EDT
Investigating
We are currently investigating a performance issue causing slow response times for the application dashboard. Our engineering team is working to identify the root cause.

Call routing and DNI is unaffected.
Posted 18 days ago. Aug 02, 2019 - 15:58 EDT
This incident affected: Application Dashboard.