Slow Calls Reporting Performance

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted Jul 19, 2022 - 17:08 EDT

Monitoring

A fix has been implemented and we are monitoring the results. At this time, reporting availability is restored and limiting mitigations have been removed.
Posted Jul 19, 2022 - 15:13 EDT

Update

We are aware of and investigating a partial outage that is impacting reporting in the application. API queries against the calls endpoints are also impacted. Call routing is not impacted.
Posted Jul 19, 2022 - 11:54 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 19, 2022 - 10:48 EDT

Identified

We are aware of and investigating mitigations for an issue causing slow performance for reports against our calls data, including the Call Log. API queries against the calls endpoints are impacted and potentially timing out. Call routing is not impacted.
Posted Jul 19, 2022 - 10:26 EDT
This incident affected: Call Tracking (CallRail Web Application) and Integrations (API).