Lead Center iOS mobile app users not receiving calls
Incident Report for CallRail
Postmortem

On November 22, 2022, a new version (v2.0.1) of the Lead Center iOS app was released to the App Store. There were changes made to the app to better support functionality when the app had been force closed by the user and to better support how calls are handled by the app. The release was thoroughly tested on multiple devices and OS versions by engineering, QA, and the product team with no issues. As the app started to scale up in production across a larger set of users, some users began to experience issues, resulting in one key impact:

  • Some users were unable to receive calls in the iOS Lead Center App, if they force closed the app.

The was resolved by updating the app so that it registers with the notification server as early in its lifecycle as possible. This ensures that if the app is force closed, it will still receive an inbound call notification and restart so it can accept the call. Version 2.0.2 has now be released to the App Store for download.

  • We recommend that users update to the latest version (v2.0.2)

We are continuing to work on an additional issue that limits access to the active call screen after the app has been forced closed. For this reason, we continue to recommend not force closing the app to ensure the best experience.

Posted Dec 02, 2022 - 16:28 EST

Resolved
A new version of the Lead Center iOS mobile app (version 2.0.2 (2)) is available from the App Store.

For users with auto-update enabled, the app will update automatically. Other users will need to update to the new version of the app from the App Store. We will continue monitoring performance of the new version.
Posted Dec 01, 2022 - 18:54 EST
Update
We have submitted a fix to the Apple App Store. As soon as they approve the updated app, it will be released. The fix version will be 2.0.2 (2). For users with auto-update enabled, the app will update automatically. Other users will need to update to the new version of the app from the App Store. We will update this page as soon as the new version is available.
Posted Dec 01, 2022 - 18:31 EST
Identified
The issue has been identified. Our team is working on implementing a fix. We appreciate your patience as we continue to work towards resolving this issue.
Posted Dec 01, 2022 - 14:51 EST
Update
Our team is continuing to investigate the issue of Lead Center iOS mobile app users intermittently not receiving calls. We will post updates as we learn more.
Posted Dec 01, 2022 - 11:45 EST
Investigating
We have received several reports of users using the Lead Center iOS mobile app intermittently not being able to receive calls. Our team is currently investigating this issue and will post an update as we learn more.
Posted Dec 01, 2022 - 10:37 EST
This incident affected: Lead Center (Lead Center Mobile App).