Application Delays
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 18:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 18:27 EDT
Investigating
Our monitoring has revealed increased delays in some internal systems. Some functions in the web application may be disrupted, but call routing is unaffected.
Posted Apr 12, 2024 - 17:36 EDT
This incident affected: Call Tracking (CallRail Web Application) and Call Recording, Call Transcription.