Sign-in Issues on CallRail Web Application
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 11:25 EDT
Investigating
We are receiving reports of errors when logging in from a small subset of users. We are actively working on a resolution and apologize for any disruptions you are experiencing related to this issue.

In the meantime, deleting your cookies for the CallRail application should allow you to sign in.
Posted Mar 19, 2024 - 10:37 EDT
This incident affected: Call Tracking (CallRail Web Application).