Degraded reporting application performance
Incident Report for CallRail
Resolved
This incident has been resolved. During this performance degradation, CallRail stopped automatically detecting duplicate form submissions. We have restored this functionality and reprocessed duplicate detection for all forms submitted during the incident.
Posted 3 months ago. Jun 21, 2019 - 15:56 EDT
Identified
We've identified the cause of the performance issue and have deployed code changes to mitigate the problem. Application performance is improving.
Posted 3 months ago. Jun 21, 2019 - 12:50 EDT
Investigating
We are currently investigating slow performance of the CallRail reporting application. Call routing, recording and DNI are unaffected.
Posted 3 months ago. Jun 21, 2019 - 11:51 EDT
This incident affected: Application Dashboard.