Long delay in call recording availability
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Nov 29, 2021 - 16:21 EST
Identified
Our data indicates current degraded call recording performance is due to slow performance at one of our telephony providers, perhaps related to high post-holiday volume on their network. We are pursuing the issue with our vendor and will continue to investigate workarounds to minimize customer impact.
Posted Nov 29, 2021 - 13:42 EST
Investigating
We are investigating an issue that is causing a delay in the availability of call recordings. Caller ID data for Lead Center calls are also impacted.
Posted Nov 29, 2021 - 12:38 EST
This incident affected: Lead Center (Lead Center General) and Call Recording.