Degraded Application Functionality
Incident Report for CallRail
Resolved
We have identified and corrected the cause of the latency issues surrounding phone calls and reporting. Monitoring improvements will be made to aid earlier detection in future, and all applications are fully operational.
Posted Aug 05, 2022 - 10:04 EDT
Monitoring
The latency issues around phone calls in Lead Center are resolved at present. We are monitoring the application for further concerns.
Posted Aug 05, 2022 - 09:31 EDT
Investigating
We are currently experiencing degraded service with our Lead Center platform. Calls will continue to route although there may be a delay in being able to view call data and report information through the CallRail or Lead Center web application.
Posted Aug 05, 2022 - 08:57 EDT
This incident affected: Lead Center (Lead Center General, Lead Center Web Application, Softphone).