Lead Center Outage
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 16:55 EDT
Update
Lead Center functionality has been restored and we are actively monitoring for further disruptions.
Posted Jul 12, 2021 - 14:41 EDT
Update
Lead Center is currently experiencing an outage that's preventing inbound/outbound calls from functioning and other real-time updates are also delayed. We are actively investigating the issue.
Posted Jul 12, 2021 - 14:29 EDT
Monitoring
A fix has been identified and implemented, we are actively monitoring the results.
Posted Jul 12, 2021 - 13:48 EDT
Investigating
Lead Center is currently experiencing an outage that's preventing inbound/outbound calls from functioning and other real-time updates are also delayed. We are actively investigating the issue.
Posted Jul 12, 2021 - 13:36 EDT
This incident affected: Lead Center.