Lead Center Outage
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 22:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2021 - 22:31 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 28, 2021 - 22:14 EDT
Identified
Starting at 8:45pm Eastern, some parts of Lead Center web application became unavailable due to some technical issues. We are investigating and a fix is underway.
Posted Apr 28, 2021 - 22:14 EDT
This incident affected: Lead Center.