Intermittent delays
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 16:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2022 - 16:12 EDT
Investigating
We are investigating reports of intermittent delays impacting processing of call-related events, call recordings, and Lead Center features.
Posted Mar 14, 2022 - 15:59 EDT
This incident affected: Call Recording and Lead Center.