High call event load
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Oct 26, 2021 - 14:56 EDT
Monitoring
We have identified and addressed this issue, and continue to monitor the status of the platform to ensure it does not recur.
Posted Oct 26, 2021 - 12:44 EDT
Investigating
We are currently investigating high call event load on our services that is causing delayed call routing and reduced availability of caller ID data.
Posted Oct 26, 2021 - 11:35 EDT
This incident affected: Lead Center (Lead Center General), Call Tracking (Call Routing), and Call Recording.