Degraded Dashboard Performance
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Aug 06, 2022 - 15:35 EDT
Monitoring
Application performance has recovered to expected levels.
Posted Aug 06, 2022 - 15:23 EDT
Identified
Our team is currently remediating database performance issues leading to slow dashboard performance for a subset of customers. The source of the problem has been identified and we are currently working to restore full performance.

If your dashboard is affected, it may help to select a shorter date range.
Posted Aug 06, 2022 - 13:16 EDT
This incident affected: Call Tracking (CallRail Web Application).