Issues with Lead Touchpoint Creation
Incident Report for CallRail
Resolved
Our engineers have finished each of the tasks associated with this and the issue is now resolved.
Posted Mar 25, 2024 - 21:15 EDT
Update
The fix has resolved the issue and tasks to backfill missing data are continuing to run. We will post a final update when these tasks are complete.
Posted Mar 22, 2024 - 19:07 EDT
Monitoring
Earlier this afternoon we discovered an issue related to attribution data (source, medium, campaign, keywords, landing page, etc).
Impacts of issue include
* Email notifications (for calls, texts, and forms) being sent without attribution data
* Integration events being sent without attribution data or in some cases, not sent at all
* Attribution data not sent in the responses for API calls
* Attribution data not showing or incomplete in the app dashboard - home page, caller timeline, activity logs, reports
* Lead attribution data not showing in Lead Center when handling calls, forms, and texts

Our engineers have implemented a fix and are now standing by as they continue to monitor for any latent concerns.
Posted Mar 22, 2024 - 18:05 EDT
Identified
We've identified the cause of the issue and are working to implement a fix.
Posted Mar 22, 2024 - 17:06 EDT
Investigating
We are investigating possible interruption in the creation of Lead Touchpoints are investigating the cause.
Posted Mar 22, 2024 - 16:12 EDT
This incident affected: Call Tracking (CallRail Web Application) and Lead Center (Lead Center Web Application).