Call routing issues for Lead Center

Incident Report for CallRail

Resolved

Our third party vendor will continue monitoring for a while, but our services are all functioning as expected.
Posted Jul 14, 2025 - 14:51 EDT

Monitoring

The third party provider has resolved their issue and is in monitoring. Our own error rate seems to have recovered, so we believe the issue is resolved, but will continue monitoring for a short time.
Posted Jul 14, 2025 - 14:09 EDT

Investigating

We are hearing reports that an upstream carrier may be having trouble resulting in some call routing failures for our Lead Center customers. We are investigating
Posted Jul 14, 2025 - 12:59 EDT
This incident affected: Lead Center (Softphone).