Reporting Dashboard Outage
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jun 13, 2021 - 14:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2021 - 11:51 EDT
Update
We are continuing to investigate this issue.
Posted Jun 13, 2021 - 11:22 EDT
Investigating
We are currently investigating an issue affecting the Reporting Dashboard.
Posted Jun 13, 2021 - 11:09 EDT
This incident affected: Application Dashboard and Lead Center.