"Call back" option not displaying in the Analytics section

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted Nov 12, 2024 - 12:29 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2024 - 11:56 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 12, 2024 - 10:55 EST

Investigating

We are currently investigating an issue that is causing the "call back" button to not display in various pages of the Analytics section, including the Activity logs and the Lead timeline page.

Call routing and reporting are not impacted.
Posted Nov 12, 2024 - 10:34 EST
This incident affected: Call Tracking (CallRail Web Application).