Google Ads Call Details Forwarding Issue

Incident Report for CallRail

Resolved

This issue has been resolved.
Posted Apr 12, 2025 - 12:53 EDT

Monitoring

Google Ads Call Details Forwarding calls should now be returning to normal. Though we will continue to monitor this to ensure the issue has been fully resolved.
Posted Apr 12, 2025 - 12:41 EDT

Identified

We have identified the root cause of this issue and are working to resolve it.
Posted Apr 12, 2025 - 12:05 EDT

Investigating

We are investigating reports of some dropped calls for Google Ads Call Details Forwarding to CallRail trackers. Other calls are routing correctly and reporting and access to CallRail are unaffected.
Posted Apr 12, 2025 - 11:44 EDT
This incident affected: Call Tracking (Google Ads Call Details Forwarding).