Delay in Caller ID information in Lead Center

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted Sep 06, 2023 - 17:44 EDT

Update

Our third-party provider's fix was successful and we are no longer seeing delays in receiving caller ID information. However, we continue to actively monitor the situation. We apologize for any inconvenience this incident may have caused.
Posted Sep 06, 2023 - 17:01 EDT

Monitoring

Our third-party provider has implemented a fix. We are still seeing some delays in caller ID information and are actively monitoring the situation. We apologize for any inconvenience this may cause.
Posted Sep 06, 2023 - 14:26 EDT

Investigating

We are currently experiencing a delay in receiving caller ID information from our 3rd party identity resolution provider. Only Lead Center customers are affected at this time. Calls are unaffected and routing as expected.
Posted Sep 06, 2023 - 12:13 EDT
This incident affected: Lead Center (Lead Center General).