Google Ads disruption of service
Incident Report for CallRail
Resolved
Google has marked the incident as resolved.
Posted Mar 18, 2024 - 15:58 EDT
Monitoring
Google Ads is reporting disruptions to its Ads Manager service, which includes the APIs used by our integration.
https://ads.google.com/status/publisher/incidents/Qv2RhZ21A54UJTPVDodp

Customers using CallRail's Google Ads Integration may experience degraded service or intermittent failures due to issues with the upstream provider, including delayed conversion reporting data and missing or incorrect CPL, keyword, and campaign data. Customers may also experience issues configuring or authorizing the Google Ads Integration on CallRail's platform.

We are closely monitoring the fix and will report when service is restored for all customers.
Posted Mar 18, 2024 - 09:19 EDT
This incident affected: Integrations (Google Ads).