Degraded Application Performance
Incident Report for CallRail
Resolved
This incident has been resolved
Posted Aug 07, 2024 - 16:40 EDT
Monitoring
We have identified a product update that was negatively impacting performance, and have reverted that change. Performance is recovering back to expected levels.
Posted Aug 07, 2024 - 15:47 EDT
Update
We are continuing to investigate this issue.
Posted Aug 07, 2024 - 15:12 EDT
Investigating
We are investigating delays with reports and dashboards loading. This may result in notifications and data flowing via webhooks being delayed as well. We are actively working to resolve this issue. We apologize for any inconvenience this may cause.
Posted Aug 07, 2024 - 15:01 EDT
This incident affected: Call Tracking (CallRail Web Application) and Lead Center (Lead Center General).