New Customer Signups Interrupted
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 22:06 EST
Monitoring
We have re-enabled new trial signups and are monitoring closely. Services for existing customers continue to be unaffected.
Posted Nov 15, 2021 - 14:29 EST
Investigating
We are investigating a possible outside attack against our customer signup service, and signups have been temporarily disabled. Services for existing customers are unaffected.
Posted Nov 15, 2021 - 11:21 EST