Call Log intermittently failing to populate

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted Apr 12, 2024 - 12:15 EDT

Identified

We have identified an issue with the Call Log intermittently failing to populate or loading slowly. Calls are still being tracked normally. We apologize for any inconvenience this may cause.
Posted Apr 12, 2024 - 11:28 EDT
This incident affected: Reports.