Poor dashboard performance
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 12:23 EDT
Monitoring
We are investigating a database issue that was causing poor performance in our application dashboard; we have made resource changes to address this issue and are monitoring the results. Calls are routing normally.
Posted Jun 23, 2020 - 11:10 EDT
This incident affected: Application Dashboard.