Error when creating a new account in Account Center
Incident Report for CallRail
Resolved
We've investigated and determined that these errors do not currently have an impact on the ability to use the CallRail application or create new accounts.
Posted Jan 20, 2023 - 11:23 EST
Investigating
We are currently investigating an error when creating a new account in Account Center and working on a fix.
Posted Jan 20, 2023 - 11:07 EST