Intermittent Lead Center Slowness & Call Connection Issues
Incident Report for CallRail
Resolved
Our teams are confident this issue is resolved. All call log data and recordings should be fully restored. All systems are functional and in a healthy state. We thank you for your patience as we processed the delayed recordings and data in the call log and apologize for any inconvenience this has caused.
Posted Jun 21, 2023 - 11:15 EDT
Update
We are confident that the ongoing issue has now been resolved and all systems are functioning as expected. Missing data and recordings from this morning have been restored. We have teams working to restore log data for calls that were placed between 9:00am and 12:30pm EDT on Monday June 19th, 2023. We expect to make another update to this incident no later than 24 hours from now.
Posted Jun 20, 2023 - 12:19 EDT
Update
We are monitoring new reports this morning of issues with intermittent slow updates of call statuses and call connection issues for some of our Lead Center customers. Our engineers have identified the issue and implemented a solution. We believe the problem to be resolved, but will continue to monitor.
Posted Jun 20, 2023 - 11:04 EDT
Update
The incident from earlier today has been resolved and all systems are functioning as expected. We have teams working to restore log data for calls that were placed between 9:00am and 12:30pm EDT on Monday June 19th, 2023.

We expect to make another update to this incident no later than 24 hours from now.
Posted Jun 19, 2023 - 18:27 EDT
Update
Our engineers are actively working on restoring the call log data. We will post updates as we learn more.
Posted Jun 19, 2023 - 16:19 EDT
Update
The main issue is resolved. Our engineers are continuing to work to populate missing call log data. We will post updates as they become available.
Posted Jun 19, 2023 - 14:46 EDT
Monitoring
Our engineers have implemented a solution and are continuing to monitor the situation. We will post updates as we learn more.
Posted Jun 19, 2023 - 13:29 EDT
Identified
Our engineers believe to have identified the root cause of this issue and are working on implementing a fix. We will post updates as they become available.
Posted Jun 19, 2023 - 13:07 EDT
Update
Our engineers are continuing to troubleshoot this issue.
Posted Jun 19, 2023 - 12:11 EDT
Update
We are continuing to investigate this issue and will post updates as we learn more.
Posted Jun 19, 2023 - 11:30 EDT
Investigating
We are investigating issues with intermittent slow update of call statuses for all customers, and call connection issues for some of our Lead Center customers.

We are actively working to resolve this issue. In the meantime, your calls will continue to be tracked, but attribution data may not be available in real-time, and some calls may appear to persist in an 'in progress' state after the call has ended. We apologize for any inconvenience this may cause.
Posted Jun 19, 2023 - 10:28 EDT
This incident affected: Call Tracking (CallRail Web Application), Lead Center (Lead Center General), and Integrations (Webhooks).